Sparkol Help

Topic not covered?

Start a new topic

Reveal Fill Wihtout Outline

Is there a way, similar to the "transparent stroke trick," to reveal a filled object without VS first trying to outline the object?

I would think, if the filled object had no stroke, that VS would not try to create one - but it seems to every time. I have the transparent stroke overlay in place to reveal the fill of the under layer, but the hairline outline that VS is doing is killing the effect.



Yes normally a fill with no strokes will not draw any outlines first (for properly made SVGs).

1) If it is a JPG or PNG, choose a different draw style
2) If it is an SVG, You could try deleting the SVG and re-adding it to videoscribe.
3) sometimes videoscribe will outline perfectly straight vertical or horizontal paths, so you might see a problem with a square path for example. You can fix it by pulling out the node handles and making the lines slightly less perfect.

please upload the SVG if you would like specific feedback.

-Mike (videoscribe user)

Thank you. I will upload the SVG in question later today when I return to my office.

I have deleted and re-added several times, and there are no 90 degree angles (already been to THAT  horror movie!!


Here is the file I spoke of.

Thank you so much for your help.



rx.svg rx.svg
4.54 KB
The SVG you attached does not draw an outline when I import it into videoscribe version 1.3.26 or version 2.2.0.

If the image orginally had a stroke and then you updated the SVG to remove the stroke... but you continued to import the old version from your "recently used" images instead of browsing to the location where the new one is saved on your hard drive... that would explain your problem.  By default, when you open the Add Image menu, you see recently used images. Click the folder icon in the lower left of the Add Image menu to browse your hard drive.

-Mike (videoscribe user)


No.  Actually,  I delete the previous version of any image from the "recently used" list before I browse to the file again. I can assure you this file does NOT render properly on my computer. 

The image never had a stroke, and it was type which was converted to outlines, which on my setup defaults to no stroke. 

I will try it again,  but I've tried it 3 times thus far. 


Weird.  Just to confirm the problem...It actually draws the entire black outline of the RX before it fills in the (black) color?

if all else fails, restart videoscribe and try it in a new empty scribe just to see if you can get it to work right under "some" circumstances.

-Mike (videoscribe user)

Yes, it draws a hairline outline, then fills as it should.

I will try it in an empty project space and let you know what happens.

Thanks for staying with this.



Well, indeed, it worked in an empty project. I then copied and pasted it into my main project, and it continued to work.

First, thank you for all the help.

Second, what the ???? Obviously something is not updating the cache within the VS program, at least on my machine. At least for this particular problem, I will now know what to do. But I have to wonder whether my problems with line weights are due to a similar issue. And how would I tell?

Again, thank you.



Glad you got it to work!

I think I had this problem once, and I can't account for it. I seem to remember getting an outline on something and repeatedly saving and importing it, and then (maybe) eventually restarting Videoscribe before it worked correctly.

Like you said, this may involve a caching problem. Possibly it is related to other bugs that sometimes occur when Videoscribe's memory usage gets close to its 1.7 GB limit.

Saving a copy of your scribe with a new name and then restarting Videoscribe and opening the new copy can sometimes resolve a variety of bugs, especially failure to render and some freezing and crashing issues. Simply saving, restarting and opening (without a new copy) might be sufficient.

I think that in most cases, bugs or problems can be avoided by following TIPS to Avoid or Fix Videoscribe freezes, crashes, slowdowns, failure to export, or erratic behaviours.   But

-Mike (videoscribe user)


Login to post a comment