Sparkol Help

Topic not covered?

Start a new topic

undo / redo (RR-786)

hello, please can there be a proper redo / undo function which covers all the kind of applications that crop up with everyday use? many thanks. 

8 people like this idea

Seems simple enough to add.

developing on this - i've just grouped some elements in one frame and then tried to resize them all at once by dragging one of the group corners (ie as one would do a single object).

however, seems you can't do this in scribe - instead the group positioning of the items goes out of whack when they are resized.

but, now that 'error' on my part can't be undone so now i have to resize everything individually again?

a proper undo function would save a lot of time for this sort of thing. or am i wrong?


Yes, undo and redo are not ready for primetime. Aside from not being on the menu, so one would not know the capability existed, the functions do not work properly. I cannot undo anything without wildly strange results. Resizing text or changing a font are destructive edits, and must be deleted and the element readded.

Am I missing something?



Hi Nick/ Mark,

Currently you can undo resizing a single element, or changing it's position. We are working expanding this feature to cover more actions. In the meantime if you need undo resizing multiple elements the fastest way to do this would be to select your images again and use the handles to drag them back to the original size.

Thank you for responding. Unfortunately, that means that undo./redo as currently implemented is useless for any work I do. Further, undo/redo for a single element should be noted as such. Any computer user would rightly assume that undo/red should act in VideoScribe as it does in ANY standards-compliant program. I am surprised that Apple/Microsoft have not taken Sparkol to task for this.

It would seem that at this juncture in VideoScribe's development, there is a tug-of-war going on between the consumer-lite "app" it started out as, and the more useful, professional "program" it aspires/promises to be. It is going to be challenging for both its developers and users like me to navigate the very difficult, and sometimes very disappointing "in-between" in the meantime.



Daniel, you say that "Currently you can undo resizing a single element, or changing it's position." For me changing the position only works a fraction of the time. Has anyone else mentioned this? Or is there something that I'm doing in some cases and not others (that you can guess at without peering over my shoulder).

I'm working in 2.2.0

But, yes... undos for other things would be great.

Yes. See my entries above. Neither Undo nor Redo work consistently, if at all, on a single or multiple images.



So there ain't any Ctrl + Z undo short cut? or even undo command?  Thanks 

Hi all,

David and Mark - Some other users have reported inconsistent results when using undo/redo. We have raised it with our development team and any fixes for this issue will be included in future updates. I understand that this doesn't fix the usability issue for you right now, but this is something that we are working on.

Angus- there is a CTRL+ Z undo shortcut that can undo resizing a single element, or changing it's position, but please note the above.

I'll add my vote for the need for better Undo and Redo support. I don't see a button or menu item by those names. That would help. Shift-Cmd+Z is the standard "Redo" on Mac. I should be able to go back and forth in history by using "Cmd+Z" and "Shift-Cmd+Z", but that does not work.

I was wrong: Undo and Redo are in the context menu.

Still no Undo command after three years???

Login to post a comment