Sparkol Help

Topic not covered?

Start a new topic

Need the older version of Videoscribe

I cannot use the new version of Videoscribe I need to be able to delete this and download the older version. Can someone help me please.


Ralph D.

On the download page, scroll down to "Previous versions" and click either the mac or windows link to download version 2.3.7

-Mike (videoscribe user)

Login to post a comment