Sparkol Help

Topic not covered?

Start a new topic

What determines the bounding box around my imported drawings?

What determines the bounding box around my imported drawings? they arent centered on my images and this makes it very difficult to size things because the fit to screen button pays attention to the box. Can i change this? I am trying to make my drawings all the same size and i have no clue how to do this in VS. I had exported the SVGs from illustrator at all the same height and now they are different in VS. 

Additionally, when i correct the location of the image on the canvas then save, either to cloud or disk, and then re-open the file it reverts back to being off center.

the bounding box ignores blank space and if that is what you are asking. It will be just large enough to enclose all paths in the SVG (including transparent and hidden ones.

If you want to force the size of a bounding box to be larger, include a zero opacity filled circle (or ellipse) with no stroke in your SVG.

Keep in mind if you mak your bounding box larger, your art imports at a smaller size and then if you scale it up it may be more blurry.

also: http://help.videoscribe.co/support/discussions/topics/1000070696
-Mike (videoscribe user)

 

To save the camera position for a specific element, place the element where you want it, then with the element still selected, click the "set camera" icon in the lower right corner of the screen .

 

I am not finding that to be the case, included is an image with the bounding box as it appears in VS and as it appears in inkscape (drawn in AI) as well as the SVG.


atest.svg atest.svg
40.6 KB
If I understand correctly, YOU use inkscape and you received the file as an AI file from someone else ... but it was probably originally created in some other rendering software other than illustrator.

If I had to guess, I would say the bounding box problem and the way it draws in videoscribe are both a result of extra data saved in the file by a newer version of inkscape or adobe illustrator. Please refer to the link I provided for more details.

I resaved the file using save settings similar to the ones in the link I provided, and it fixed your bounding box problem, and also made it draw a lot better in videoscribe. The structure of the file is a bit weird, but surprisingly it worked pretty well after applying different save options!

If you are using inkscape, your easiest solution is probably going to be to install an older version of inkscape from inkscape's website (I think it is discussed in the link I provided).

The resaved version is attached. Hope it helps.

-Mike (videoscribe user)


 



Login to post a comment