Sparkol Help

Topic not covered?

Start a new topic

MACOS 10.5.8

Video scribe doesn't open with my version of MACOS 10.5.8 on macbookpro

what are the minimum requirements of the MACOS version

To run VideoScribe on a Mac you need at least:

OSX 10.7 or higher

An intel 1.83GHz processor

1GB of RAM

A screen that can handle 800x768 resolution


Login to post a comment