Sparkol Help

Topic not covered?

Start a new topic

Lines get thicker when drawing is done

Hi!


Several others have posted questions on this topic before, but the answers don't seem to help me. I've created drawings in Illustrator 5.5 with a line thickness of 1 px and on an 1500x1500 px artboard. All paths and nothing grouped. I save the SVG as shown in the attached file. When I import it to Videoscribe, the images are drawn with a thin line which as soon as the drawing is done gets a bit thicker. This looks kind of awful, and I don't know how to get the lines in the drawings to be of consistent thicknes throughout the animation. Please, help me to understand how to get rid of the shift in line thickness.


/Anna

svg.png svg.png
38.7 KB

Hi Brian,

Do you have the same issue with this SVG file?

Can you create a new project file and import this one.

Does the same thing happen when you do?

If you're resizing something, ensure you set the camera position afterwards.




That was it.  I wasn't setting camera lock.

Thanks, Joe.  Sorry for griping.  :)

 

Is there a way to rescale by percentage manually?
With the keyboard, and not with the trackpad?
I'm resizing several scribes that need to match size exactly,
and I can't get exact numbers by resizing thru scrolling on the trackpad.

Another issue... I am attempting to export png image sequences with transparency, and although
some transparency is preserved there seems to be an opaque layer of paper texture in the images,
such that it is not a true transparency.  Is there a way to export png's with true transparency and
not the paper texture/distress? 

You can see in this screen shot that I have a png export in photoshop above a layer
of solid black.  However, it doesn't appear solid black under the image,
it is a sort of gray, with paper texture, resulting from the texture/distress of the export.
How can I avoid this?  this is crucial to my success with this project.




 


Hi,

 I think that you have selected the top left paper texture and you need to change your selection to the default paper option which is the second one on this menu (The middle of the top row):

 


-Mike (videoscribe user)

That totally worked, thanks Mike!

 

Mike, or anyone,

do you have any idea how to manually scale the image numerically with the keypad,
rather than scrolling with the trackpad? 

I have to scale several scribes by exactly the same amount,
and using the trackpad seems to be a crap shoot at best. 

Thanks,

Brian


 

Hi,
I don't think that is currently a feature. However, there is a suggestion thread for it so you can go here: http://help.videoscribe.co/support/discussions/topics/1000065126
and click the "like" (or in this case, the  "I have this question") label at the bottom of the first post in the thread.

(Now that I look at it, I think that thread is currently categorized as a question, maybe support can move it to the suggestions section if they have a chance.)

-Mike (videoscribe user)

 

RE: The original post about thickening lines, is it really 2017 and this is still a problem that has no consistent solution? If so, I may need to stop using Videoscribe for whiteboard videos. It's really disappointing that they keep blaming CC on the SVG issues but haven't yet made updates to their own product to address the differences.


Can someone at Sparkol confirm whether or not they are actually working on solving this problem without the user having to do a bunch of workarounds?

Can someone of sparkol please answer this question? I am also still looking for a solution.


We don't have a solution or fix for this issue but there are plenty of suggestions on this thread. Unfortunately it may not be possible to eliminate the thickening effect completely. If you have an image that is causing a particularly big issue and cannot figure out how to get it to work better, attach it here and I'll be happy to take a look. If you'd rather not post the image on the public forum, open a support ticket and attach it to that.

Thank you. I have opened a support ticket and added an illustration. I am waiting for response. I've noticed that it gets better when I use thicker lines. When I was using CS6 I'd never had this problem before, so I was not amused that this problem suddenly appeared. Have a look at this animation (link below), where I had no problem. That what before I installed AdobeCC2017 and High Sierra. Maybe that last thing has something to do with it too. Because when I now draw in CS6 and do exactly the same, I have these "thin lines and "plopping" to thicker lines problem". Strange!! 


By the way: this thread is very long, it takes lots of time to read, is it possible to make a summary of the suggestions (that are working), so that in the future other users can more quickly be helped and get les frustrated? That would be a great service.  And... is it true that Sparkol is not planning to ever fix this big bug? I think it is important to be honest about the pros and cons of the program, so people have a choice. Thank you!!


https://vimeo.com/237079324, password: willemijnontwerp

I will create a help article summarising the the suggestions in this thread.

It seems that the problem of increasing line thickness after the image is drawn, has to do with a difference in the SVG document size and its viewbox. In terms of SVG, this is about the following properties:

   width="270"

   height="180"

   viewBox="0 0 71.437498 47.625001"

The above values are taken from a drawing that shows the line thickening problem. 

The viewBox defines a rectangle in 'user space" (see: viewBox on Mozilla). If the document size (width and height) is larger than the viewBox, the line thickening problem occurs.

You can easily make the document size equal to the viewBox size in Inkscape, by by setting the scale in File>Document Properties... >Page to 1. This means that user units equal pixels (pixels are required as unit by Videoscribe).

Doing so for the document whose values I gave above, removes the line thickening problem.


I find it useful to set the page size to the actual drawing size, too. This prevents surprising sizing on importing into Videoscribe. First select all elements in your drawing (ctrl-a). Then, on File>Document Properties... >Page, click "Resize page to drawing or selection".

Hi,

Would you mind attaching the SVG that has the thickening problem and the fixed SVG?

I have tested an SVG image for which the document size and viewbox are identical whole numbers and the thickening problem remains. I would like to look for other differences in the files.



Regards,

Mike (videoscribe user)


Login to post a comment