Sparkol Help

Topic not covered?

Start a new topic

Reduced quality during drawing proces.

 Hi.

I'm going crazy, and have searched for an answer for hours now.

Just bought videoscribe, and have a video i want to make. Already made the SVG's for it.

The problem is, when the hand is drawing, the quality is very poor, making the finished result suddenly pop out as being alot smoother.

I have tried all image qualities in videoscribe, and i have tried different thickness of the lines, and i does reduced the problem, but it's a very poor fix. I have tried different resolutions of svg's, but since it's videoscribe that has the temporary quality reduction, it does nothing really.


Hope you can help!

Two pictures to demonstrate how the thin lines are really messed up when drawing, and then back to normal once it's done.

These are at quality 4000. Drawn with a basic line 1px thick.


Hi,

If you are using illustrator CC then I would recommend resaving the SVG in an older version of illustrator or resaving it in inkscape (free at inkscape.org).  Illustrator CC has  "new" pencil and pen tools which cause problems like this in videoscribe.

related thread: http://help.videoscribe.co/support/discussions/topics/1000033902

Otherwise you probably need to upload the SVGS to get specific advice.

Maybe the lines are thin filled paths instead of stroked paths or something else....

-Mike (videoscribe user)

 

 Hi Mike.


I was using inkscape at first, and have tried illustrator now that i had trouble and now difference.

Tried to save as an older format of AI and resave it as SVG, and it clearly reduced the line quality all around, so that the change wasnt as clear, but the drawing was very rough that way.


It happens when i use all line and pencil tools, and it shouldn't be with fill, in any of my pictures.

Have a look at the example i showed with the pictures.

Thanks for your help.


Hi,

When VideoScribe finishes drawing an SVG image it creates a bitmap of that image- this is what you will see on your scribe after an image is drawn, and why you can get a slight 'popping' effect on some SVGs, particularly those with thin lines. You should be able to reduce this effect by slightly increasing the thickness of your lines.

Please let us know if this does not resolve the problem for you, or if you need any further information on this.

 Hi Daniel.

I have tried serveral different sizes, but are there any sizes (in px) that are better then others?

The popping effect is quite obvious with lines under 10pix, it seems.

Hi Steps Service,

I'm taking a look at your SVG and I ended up with about the same results that you did, unfortunately. I don't know of a way to completely eliminate that thickening after the drawing is done. The second line in particular looks a bit pixelated when it is drawn, due to the angle.

a few notes though:
1) when I try to open it I get an error "the operation cannot complete because of an unknown error [PGFp]". I'm not sure if the error is because I am using an older version of illustrator (CS4) but it might be a result of "not-the-best" save settings on the SVG or something.
2) I manually edited the SVG and deleted the huge chunk of PGF data and resaved it as "my_lines_edited.svg" (please see attached). Now I can open it in AI CS4. As you mentioned, everything looks like it was done the "right" way. just 1pt strokes and no fills.
3) The new file size is only 3kb instead of 926.7 kb and I think it draws the same way as the 926.7 kb version. (you may want to experiment with your saving options as larger files may contribute to slowdowns or freezes in videoscribe)
4)  a 2 pt  stroke instead of a 1 pt stroke looks better in my opinion, but still thickens after the drawing is done. (did you say you were seeing pixels instead of points as your unit of stroke width?)

(tested in version 1.3.26)


-Mike (videoscribe user)



 


Hi there, I had a look at the SVG file and when imported into InkScape I noticed that the stroke width was set to 0.00


I have increased this and attached the resulting SVG file.

Please note my default image quality is set to 1920 presently.




I appreciate your help guys, but it seems the result is the same with the new one Mike edited.
Also the one that Joe made is thicker and therefor it renders a little smoother.

I have increased thickness of lines on all my drawings, and as long as i keep it at around 10-12 it seems to be running pretty well.

Thanks for the replies though :)

 


Login to post a comment